Commit 2e6efbbb authored by jaywink's avatar jaywink
Browse files

Bump used Node version to 10

parent b5ad70f0
Pipeline #6531 passed with stages
in 14 minutes and 16 seconds
......@@ -27,7 +27,7 @@ stages:
lint:
stage: lint
image: node:8
image: node:10
cache:
paths:
- node_modules/
......@@ -65,7 +65,7 @@ test_frontend_unit:
stage: test_frontend
environment:
name: production
image: node:8
image: node:10
cache:
paths:
- node_modules/
......
......@@ -11,7 +11,7 @@ RUN rm /bin/sh && ln -s /bin/bash /bin/sh
RUN mkdir /usr/local/nvm
ENV NVM_DIR /usr/local/nvm
ENV NODE_VERSION 8.15.0
ENV NODE_VERSION 10.24.1
# Install nvm with node and npm
RUN curl https://raw.githubusercontent.com/creationix/nvm/v0.33.11//install.sh | bash \
......
......@@ -22,7 +22,7 @@ Python Virtualenv
Python 3.6 is the minimum supported version. Ensure the following are installed:
* Python system dependencies
* NodeJS (version 6-8)
* NodeJS (version 10)
* PostgreSQL server
* Redis
......
......@@ -56,7 +56,7 @@ Install system packages
Install Node.js
'''''''''''''''
Node.js version 6-8 has been tested to work. Install one by following the `Node.js install guides <https://nodejs.org/en/download/package-manager/#debian-and-ubuntu-based-linux-distributions>`_.
Node.js version 10 has been tested to work. Install one by following the `Node.js install guides <https://nodejs.org/en/download/package-manager/#debian-and-ubuntu-based-linux-distributions>`_.
If you already have a system Node installed which is either too old or newer, consider using [NVM](https://github.com/creationix/nvm) to install a specific version for Socialhome only.
......
......@@ -38,7 +38,7 @@
"time-grunt": "~2.0.0"
},
"engines": {
"node": ">=6 <9"
"node": ">=10 <11"
},
"dependencies": {
"lodash": "^4.17.21"
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment