Currently we have some license issues. We are working on it.

Commit e4164eb1 authored by Jonne Haß's avatar Jonne Haß
Browse files

update rspec suite dependencies

parent a36ffff5
......@@ -258,7 +258,7 @@ group :development do
gem "pry-byebug"
# test coverage
gem "simplecov", "0.16.1", require: false
gem "simplecov", "0.21.2", require: false
gem "turbo_dev_assets", "0.0.2"
end
......@@ -267,7 +267,7 @@ group :test do
# RSpec (unit tests, some integration tests)
gem "fixture_builder", "0.5.2"
gem "fuubar", "2.5.0"
gem "fuubar", "2.5.1"
gem "json-schema-rspec", "0.0.4"
gem "rspec-json_expectations", "~> 2.1"
......@@ -282,16 +282,16 @@ group :test do
# General helpers
gem "factory_girl_rails", "4.9.0"
gem "shoulda-matchers", "4.0.1"
gem "timecop", "0.9.1"
gem "webmock", "3.8.3", require: false
gem "shoulda-matchers", "4.5.1"
gem "timecop", "0.9.4"
gem "webmock", "3.12.2", require: false
gem "diaspora_federation-test", "0.2.6"
end
group :development, :test do
# RSpec (unit tests, some integration tests)
gem "rspec-rails", "3.9.1"
gem "rspec-rails", "5.0.1"
# Cucumber (integration tests)
gem "cucumber-rails", "2.3.0", require: false
......
......@@ -138,8 +138,8 @@ GEM
concurrent-ruby (1.1.8)
configurate (0.5.0)
connection_pool (2.2.3)
crack (0.4.3)
safe_yaml (~> 1.0.0)
crack (0.4.5)
rexml
crass (1.0.6)
cucumber (5.3.0)
builder (~> 3.2, >= 3.2.4)
......@@ -216,7 +216,7 @@ GEM
fabrication (~> 2.16)
uuid (~> 2.3, >= 2.3.8)
diff-lcs (1.4.4)
docile (1.3.2)
docile (1.3.5)
domain_name (0.5.20190701)
unf (>= 0.0.5, < 1.0.0)
encryptor (3.0.0)
......@@ -240,7 +240,7 @@ GEM
kostya-sigar (~> 2.0.0)
state_machines
thor
fabrication (2.21.0)
fabrication (2.22.0)
factory_girl (4.9.0)
activesupport (>= 3.0.0)
factory_girl_rails (4.9.0)
......@@ -281,7 +281,7 @@ GEM
fugit (1.4.4)
et-orbi (~> 1.1, >= 1.1.8)
raabro (~> 1.4)
fuubar (2.5.0)
fuubar (2.5.1)
rspec-core (~> 3.0)
ruby-progressbar (~> 1.4)
get_process_mem (0.2.5)
......@@ -616,28 +616,28 @@ GEM
chunky_png (~> 1.0)
rqrcode_core (~> 0.1)
rqrcode_core (0.1.2)
rspec (3.9.0)
rspec-core (~> 3.9.0)
rspec-expectations (~> 3.9.0)
rspec-mocks (~> 3.9.0)
rspec-core (3.9.1)
rspec-support (~> 3.9.1)
rspec-expectations (3.9.1)
rspec (3.10.0)
rspec-core (~> 3.10.0)
rspec-expectations (~> 3.10.0)
rspec-mocks (~> 3.10.0)
rspec-core (3.10.1)
rspec-support (~> 3.10.0)
rspec-expectations (3.10.1)
diff-lcs (>= 1.2.0, < 2.0)
rspec-support (~> 3.9.0)
rspec-support (~> 3.10.0)
rspec-json_expectations (2.2.0)
rspec-mocks (3.9.1)
rspec-mocks (3.10.2)
diff-lcs (>= 1.2.0, < 2.0)
rspec-support (~> 3.9.0)
rspec-rails (3.9.1)
actionpack (>= 3.0)
activesupport (>= 3.0)
railties (>= 3.0)
rspec-core (~> 3.9.0)
rspec-expectations (~> 3.9.0)
rspec-mocks (~> 3.9.0)
rspec-support (~> 3.9.0)
rspec-support (3.9.2)
rspec-support (~> 3.10.0)
rspec-rails (5.0.1)
actionpack (>= 5.2)
activesupport (>= 5.2)
railties (>= 5.2)
rspec-core (~> 3.10)
rspec-expectations (~> 3.10)
rspec-mocks (~> 3.10)
rspec-support (~> 3.10)
rspec-support (3.10.2)
rubocop (0.93.1)
parallel (~> 1.10)
parser (>= 2.7.1.5)
......@@ -657,7 +657,6 @@ GEM
ruby-progressbar (1.11.0)
rubyzip (2.3.0)
rugged (1.0.1)
safe_yaml (1.0.5)
sass (3.4.25)
sass-rails (5.0.7)
railties (>= 4.0.0, < 6)
......@@ -674,7 +673,7 @@ GEM
rake (>= 0.9, < 13)
sass (~> 3.4.20)
secure_headers (6.3.2)
shoulda-matchers (4.0.1)
shoulda-matchers (4.5.1)
activesupport (>= 4.2.0)
sidekiq (6.2.1)
connection_pool (>= 2.2.2)
......@@ -686,11 +685,12 @@ GEM
simple_captcha2 (0.5.0)
rails (>= 4.1)
simple_oauth (0.3.1)
simplecov (0.16.1)
simplecov (0.21.2)
docile (~> 1.1)
json (>= 1.8, < 3)
simplecov-html (~> 0.10.0)
simplecov-html (0.10.2)
simplecov-html (~> 0.11)
simplecov_json_formatter (~> 0.1)
simplecov-html (0.12.3)
simplecov_json_formatter (0.1.2)
sinon-rails (1.15.0)
railties (>= 3.1)
sprockets (3.7.2)
......@@ -716,7 +716,7 @@ GEM
thor (1.1.0)
thread_safe (0.3.6)
tilt (2.0.10)
timecop (0.9.1)
timecop (0.9.4)
timers (4.3.0)
to_regexp (0.2.1)
toml-rb (2.0.1)
......@@ -769,7 +769,7 @@ GEM
webfinger (1.1.0)
activesupport
httpclient (>= 2.4)
webmock (3.8.3)
webmock (3.12.2)
addressable (>= 2.3.6)
crack (>= 0.3.2)
hashdiff (>= 0.4.0, < 2.0.0)
......@@ -818,7 +818,7 @@ DEPENDENCIES
faraday_middleware (= 0.13.1)
fixture_builder (= 0.5.2)
fog-aws (= 3.5.2)
fuubar (= 2.5.0)
fuubar (= 2.5.1)
gon (= 6.3.2)
haml_lint (= 0.37.0)
hamlit (= 2.11.0)
......@@ -892,22 +892,22 @@ DEPENDENCIES
responders (= 3.0.1)
rqrcode (= 1.1.2)
rspec-json_expectations (~> 2.1)
rspec-rails (= 3.9.1)
rspec-rails (= 5.0.1)
rubocop (= 0.93.1)
rubocop-rails (= 2.9.1)
ruby-oembed (= 0.12.0)
rubyzip (= 2.3.0)
sass-rails (= 5.0.7)
secure_headers (= 6.3.2)
shoulda-matchers (= 4.0.1)
shoulda-matchers (= 4.5.1)
sidekiq (= 6.2.1)
sidekiq-cron (= 1.2.0)
simple_captcha2 (= 0.5.0)
simplecov (= 0.16.1)
simplecov (= 0.21.2)
sinon-rails (= 1.15.0)
sprockets-rails (= 3.2.1)
string-direction (= 1.2.2)
timecop (= 0.9.1)
timecop (= 0.9.4)
toml-rb (= 2.0.1)
turbo_dev_assets (= 0.0.2)
twitter (= 7.0.0)
......@@ -918,7 +918,7 @@ DEPENDENCIES
unicorn-worker-killer (= 0.4.4)
uuid (= 2.3.9)
versionist (= 2.0.1)
webmock (= 3.8.3)
webmock (= 3.12.2)
will_paginate (= 3.3.0)
BUNDLED WITH
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment