Currently we have some license issues. We are working on it.

Commit b4b4efba authored by Jonne Haß's avatar Jonne Haß
Browse files

drop guard dev tool

parent 7277200b
......@@ -241,13 +241,6 @@ group :production do # we don"t install these on travis to speed up test runs
end
group :development do
# Automatic test runs
gem "guard", "2.16.1", require: false
gem "guard-rspec", "4.7.3", require: false
gem "guard-rubocop", "1.3.0", require: false
gem "rb-fsevent", "0.10.3", require: false
gem "rb-inotify", "0.10.1", require: false
# Linters
gem "haml_lint", "0.35.0", require: false
gem "pronto", "0.10.0", require: false
......
......@@ -280,23 +280,6 @@ GEM
i18n (>= 0.7)
multi_json
request_store (>= 1.0)
guard (2.16.1)
formatador (>= 0.2.4)
listen (>= 2.7, < 4.0)
lumberjack (>= 1.0.12, < 2.0)
nenv (~> 0.1)
notiffany (~> 0.0)
pry (>= 0.9.12)
shellany (~> 0.0)
thor (>= 0.18.1)
guard-compat (1.2.1)
guard-rspec (4.7.3)
guard (~> 2.1)
guard-compat (~> 1.1)
rspec (>= 2.99.0, < 4.0)
guard-rubocop (1.3.0)
guard (~> 2.0)
rubocop (~> 0.20)
haml (5.1.2)
temple (>= 0.8.0)
tilt
......@@ -376,9 +359,6 @@ GEM
kostya-sigar (2.0.8)
leaflet-rails (1.6.0)
rails (>= 4.2.0)
listen (3.2.1)
rb-fsevent (~> 0.10, >= 0.10.3)
rb-inotify (~> 0.9, >= 0.9.10)
little-plugger (1.1.4)
logging (2.2.2)
little-plugger (~> 1.1)
......@@ -388,7 +368,6 @@ GEM
loofah (2.9.1)
crass (~> 1.0.2)
nokogiri (>= 1.5.9)
lumberjack (1.2.4)
macaddr (1.7.2)
systemu (~> 2.6.5)
mail (2.7.1)
......@@ -415,14 +394,10 @@ GEM
multipart-post (2.1.1)
mysql2 (0.5.3)
naught (1.1.0)
nenv (0.3.0)
nio4r (2.5.7)
nokogiri (1.11.3)
mini_portile2 (~> 2.5.0)
racc (~> 1.4)
notiffany (0.1.3)
nenv (~> 0.1)
shellany (~> 0.0)
oauth (0.5.4)
oauth2 (1.4.4)
faraday (>= 0.8, < 2.0)
......@@ -671,7 +646,6 @@ GEM
rake (>= 0.9, < 13)
sass (~> 3.4.20)
secure_headers (6.3.2)
shellany (0.0.1)
shoulda-matchers (4.0.1)
activesupport (>= 4.2.0)
sidekiq (6.2.1)
......@@ -816,9 +790,6 @@ DEPENDENCIES
fog-aws (= 3.5.2)
fuubar (= 2.5.0)
gon (= 6.3.2)
guard (= 2.16.1)
guard-rspec (= 4.7.3)
guard-rubocop (= 1.3.0)
haml_lint (= 0.35.0)
hamlit (= 2.11.0)
handlebars_assets (= 0.23.8)
......@@ -886,8 +857,6 @@ DEPENDENCIES
rails-controller-testing (= 1.0.4)
rails-i18n (= 5.1.3)
rails-timeago (= 2.18.0)
rb-fsevent (= 0.10.3)
rb-inotify (= 0.10.1)
redcarpet (= 3.5.1)
redis (= 4.2.5)
responders (= 3.0.1)
......
# frozen_string_literal: true
guard :rspec, cmd: "bin/spring rspec", all_on_start: false, all_after_pass: false do
watch(/^spec\/.+_spec\.rb$/)
watch(/^lib\/(.+)\.rb$/) {|m| "spec/lib/#{m[1]}_spec.rb" }
watch(/spec\/spec_helper.rb/) { "spec" }
# Rails example
watch(/^spec\/.+_spec\.rb$/)
watch(/^app\/(.+)\.rb$/) {|m| "spec/#{m[1]}_spec.rb" }
watch(/^lib\/(.+)\.rb$/) {|m| "spec/lib/#{m[1]}_spec.rb" }
watch(%r{^app/controllers/(.+)_(controller)\.rb$}) {|m|
["spec/routing/#{m[1]}_routing_spec.rb",
"spec/#{m[2]}s/#{m[1]}_#{m[2]}_spec.rb",
"spec/acceptance/#{m[1]}_spec.rb"]
}
watch(%r{^spec/support/(.+)\.rb$}) { "spec" }
watch("spec/spec_helper.rb") { "spec" }
watch("config/routes.rb") { "spec/routing" }
watch("app/controllers/application_controller.rb") { "spec/controllers" }
# Capybara request specs
watch(%r{^app/views/(.+)/.*\.(erb|haml)$}) {|m| "spec/requests/#{m[1]}_spec.rb" }
end
guard :rubocop, all_on_start: false, keep_failed: false do
watch(/(?:app|config|db|lib|features|spec)\/.+\.rb$/)
watch(/(config.ru|Gemfile|Guardfile|Rakefile)$/)
end
#!/usr/bin/env ruby
#
# This file was generated by Bundler.
#
# The application 'guard' is installed as part of a gem, and
# this file is here to facilitate running it.
#
require 'pathname'
ENV['BUNDLE_GEMFILE'] ||= File.expand_path("../../Gemfile",
Pathname.new(__FILE__).realpath)
require 'rubygems'
require 'bundler/setup'
load Gem.bin_path('guard', 'guard')
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment