Currently we have some license issues. We are working on it.

Commit a36ffff5 authored by Jonne Haß's avatar Jonne Haß
Browse files

update linters

parent 2412ee39
require: rubocop-rails
AllCops:
TargetRubyVersion: 2.3
TargetRubyVersion: 2.6
NewCops: enable
Exclude:
- "bin/**/*"
- "db/schema.rb"
......
......@@ -242,14 +242,14 @@ end
group :development do
# Linters
gem "haml_lint", "0.35.0", require: false
gem "pronto", "0.10.0", require: false
gem "pronto-eslint", "0.10.0", require: false
gem "pronto-haml", "0.10.0", require: false
gem "pronto-rubocop", "0.10.0", require: false
gem "pronto-scss", "0.10.0", require: false
gem "rubocop", "0.80.1", require: false
gem "rubocop-rails", "2.4.1", require: false
gem "haml_lint", "0.37.0", require: false
gem "pronto", "0.11.0", require: false
gem "pronto-eslint", "0.11.0", require: false
gem "pronto-haml", "0.11.0", require: false
gem "pronto-rubocop", "0.11.1", require: false
gem "pronto-scss", "0.11.0", require: false
gem "rubocop", "0.93.1", require: false
gem "rubocop-rails", "2.9.1", require: false
# Preloading environment
......
......@@ -66,7 +66,7 @@ GEM
fog-core
mime-types (>= 2.99)
unf
ast (2.4.0)
ast (2.4.2)
attr_encrypted (3.1.0)
encryptor (~> 3.0.0)
attr_required (1.0.1)
......@@ -286,8 +286,8 @@ GEM
ruby-progressbar (~> 1.4)
get_process_mem (0.2.5)
ffi (~> 1.0)
gitlab (4.14.0)
httparty (~> 0.14, >= 0.14.0)
gitlab (4.17.0)
httparty (~> 0.18)
terminal-table (~> 1.5, >= 1.5.1)
globalid (0.4.2)
activesupport (>= 4.2.0)
......@@ -299,8 +299,9 @@ GEM
haml (5.1.2)
temple (>= 0.8.0)
tilt
haml_lint (0.35.0)
haml (>= 4.0, < 5.2)
haml_lint (0.37.0)
haml (>= 4.0, < 5.3)
parallel (~> 1.10)
rainbow
rubocop (>= 0.50.0)
sysexits (~> 1.1)
......@@ -326,7 +327,7 @@ GEM
ffi-compiler (>= 1.0, < 2.0)
http_accept_language (2.1.1)
http_parser.rb (0.6.0)
httparty (0.18.0)
httparty (0.18.1)
mime-types (~> 3.0)
multi_xml (>= 0.5.2)
httpclient (2.8.3)
......@@ -339,7 +340,6 @@ GEM
i18n-inflector (~> 2.6)
railties (>= 3.0.0)
ipaddress (0.8.3)
jaro_winkler (1.5.4)
jasmine (3.6.0)
jasmine-core (~> 3.6.0)
phantomjs
......@@ -422,7 +422,7 @@ GEM
multi_json (~> 1.3)
multi_xml (~> 0.5)
rack (>= 1.2, < 3)
octokit (4.18.0)
octokit (4.20.0)
faraday (>= 0.9)
sawyer (~> 0.8.0, >= 0.5.3)
omniauth (1.9.1)
......@@ -456,29 +456,31 @@ GEM
validate_url
webfinger (>= 1.0.1)
orm_adapter (0.5.0)
parallel (1.19.1)
parser (2.7.0.4)
ast (~> 2.4.0)
parallel (1.20.1)
parser (3.0.1.0)
ast (~> 2.4.1)
pg (1.2.3)
phantomjs (2.1.1.0)
pronto (0.10.0)
gitlab (~> 4.0, >= 4.0.0)
pronto (0.11.0)
gitlab (~> 4.4, >= 4.4.0)
httparty (>= 0.13.7)
octokit (~> 4.7, >= 4.7.0)
rainbow (>= 2.2, < 4.0)
rugged (~> 0.24, >= 0.23.0)
thor (~> 0.20.0)
pronto-eslint (0.10.0)
rexml (~> 3.2)
rugged (>= 0.23.0, < 1.1.0)
thor (>= 0.20.3, < 2.0)
pronto-eslint (0.11.0)
eslintrb (~> 2.0, >= 2.0.0)
pronto (~> 0.10.0)
pronto-haml (0.10.0)
pronto (~> 0.11.0)
pronto-haml (0.11.0)
haml_lint (~> 0.23)
pronto (~> 0.10.0)
pronto-rubocop (0.10.0)
pronto (~> 0.10.0)
rubocop (~> 0.50, >= 0.49.1)
pronto-scss (0.10.0)
pronto (~> 0.10.0)
pronto (~> 0.11.0)
rubocop (< 1.0)
pronto-rubocop (0.11.1)
pronto (~> 0.11.0)
rubocop (>= 0.63.1, < 2.0)
pronto-scss (0.11.0)
pronto (~> 0.11.0)
scss_lint (~> 0.43, >= 0.43.0)
protobuf-cucumber (3.10.8)
activesupport (>= 3.2)
......@@ -608,7 +610,7 @@ GEM
responders (3.0.1)
actionpack (>= 5.0)
railties (>= 5.0)
rexml (3.2.4)
rexml (3.2.5)
rotp (6.2.0)
rqrcode (1.1.2)
chunky_png (~> 1.0)
......@@ -636,21 +638,25 @@ GEM
rspec-mocks (~> 3.9.0)
rspec-support (~> 3.9.0)
rspec-support (3.9.2)
rubocop (0.80.1)
jaro_winkler (~> 1.5.1)
rubocop (0.93.1)
parallel (~> 1.10)
parser (>= 2.7.0.1)
parser (>= 2.7.1.5)
rainbow (>= 2.2.2, < 4.0)
regexp_parser (>= 1.8)
rexml
rubocop-ast (>= 0.6.0)
ruby-progressbar (~> 1.7)
unicode-display_width (>= 1.4.0, < 1.7)
rubocop-rails (2.4.1)
unicode-display_width (>= 1.4.0, < 2.0)
rubocop-ast (1.4.1)
parser (>= 2.7.1.5)
rubocop-rails (2.9.1)
activesupport (>= 4.2.0)
rack (>= 1.1)
rubocop (>= 0.72.0)
rubocop (>= 0.90.0, < 2.0)
ruby-oembed (0.12.0)
ruby-progressbar (1.10.1)
ruby-progressbar (1.11.0)
rubyzip (2.3.0)
rugged (0.99.0)
rugged (1.0.1)
safe_yaml (1.0.5)
sass (3.4.25)
sass-rails (5.0.7)
......@@ -707,7 +713,7 @@ GEM
temple (0.8.2)
terminal-table (1.8.0)
unicode-display_width (~> 1.1, >= 1.1.1)
thor (0.20.3)
thor (1.1.0)
thread_safe (0.3.6)
tilt (2.0.10)
timecop (0.9.1)
......@@ -738,7 +744,7 @@ GEM
unf (0.1.4)
unf_ext
unf_ext (0.0.7.6)
unicode-display_width (1.6.1)
unicode-display_width (1.7.0)
unicorn (5.5.3)
kgio (~> 2.6)
raindrops (~> 0.7)
......@@ -814,7 +820,7 @@ DEPENDENCIES
fog-aws (= 3.5.2)
fuubar (= 2.5.0)
gon (= 6.3.2)
haml_lint (= 0.35.0)
haml_lint (= 0.37.0)
hamlit (= 2.11.0)
handlebars_assets (= 0.23.8)
http_accept_language (= 2.1.1)
......@@ -843,11 +849,11 @@ DEPENDENCIES
open_graph_reader (= 0.7.1)
openid_connect (= 1.1.8)
pg (= 1.2.3)
pronto (= 0.10.0)
pronto-eslint (= 0.10.0)
pronto-haml (= 0.10.0)
pronto-rubocop (= 0.10.0)
pronto-scss (= 0.10.0)
pronto (= 0.11.0)
pronto-eslint (= 0.11.0)
pronto-haml (= 0.11.0)
pronto-rubocop (= 0.11.1)
pronto-scss (= 0.11.0)
pry
pry-byebug
rack-cors (= 1.1.1)
......@@ -887,8 +893,8 @@ DEPENDENCIES
rqrcode (= 1.1.2)
rspec-json_expectations (~> 2.1)
rspec-rails (= 3.9.1)
rubocop (= 0.80.1)
rubocop-rails (= 2.4.1)
rubocop (= 0.93.1)
rubocop-rails (= 2.9.1)
ruby-oembed (= 0.12.0)
rubyzip (= 2.3.0)
sass-rails (= 5.0.7)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment