Unverified Commit 6185355e authored by Benjamin Neff's avatar Benjamin Neff

Merge branch 'release/0.7.8.0'

parents fa0e34f6 09a8c84a
# 0.7.8.0
## Refactor
* Make setting up a development environment 9001% easier by adding a Docker-based setup [#7870](https://github.com/diaspora/diaspora/pull/7870)
* Improve `web+diaspora://` handler description [#7909](https://github.com/diaspora/diaspora/pull/7909)
* Move comment timestamp next to author name [#7905](https://github.com/diaspora/diaspora/pull/7905)
* Sharpen small and medium thumbnails [#7924](https://github.com/diaspora/diaspora/pull/7924)
* Show full-res image in Desktop's full-screen image view [#7890](https://github.com/diaspora/diaspora/pull/7890)
## Bug fixes
* Ignore invalid URLs for camo [#7922](https://github.com/diaspora/diaspora/pull/7922)
* Unliking a post did not update the participation icon without a reload [#7882](https://github.com/diaspora/diaspora/pull/7882)
* Fix broken Instagram embedding [#7920](https://github.com/diaspora/diaspora/pull/7920)
## Features
* Add the ability to assign roles in the admin panel [#7868](https://github.com/diaspora/diaspora/pull/7868)
* Improve memory usage with libjemalloc if available [#7919](https://github.com/diaspora/diaspora/pull/7919)
# 0.7.7.1
Fixes a potential cross-site scripting issue with maliciously crafted OpenGraph metadata on the mobile interface.
......
......@@ -10,7 +10,7 @@ gem "responders", "2.4.0"
# Appserver
gem "unicorn", "5.4.0", require: false
gem "unicorn", "5.4.1", require: false
gem "unicorn-worker-killer", "0.4.4"
# Federation
......@@ -22,11 +22,11 @@ gem "diaspora_federation-rails", "0.2.5"
gem "acts_as_api", "1.0.1"
gem "json", "2.1.0"
gem "json-schema", "2.8.0"
gem "json-schema", "2.8.1"
# Authentication
gem "devise", "4.4.3"
gem "devise", "4.5.0"
gem "devise_lastseenable", "0.0.6"
# Captcha
......@@ -36,15 +36,15 @@ gem "simple_captcha2", "0.4.3", require: "simple_captcha"
# Background processing
gem "redis", "3.3.5" # Pinned to 3.3.x because of https://github.com/antirez/redis/issues/4272
gem "sidekiq", "5.1.3"
gem "sidekiq", "5.2.3"
# Scheduled processing
gem "sidekiq-cron", "0.6.3"
gem "sidekiq-cron", "1.0.4"
# Compression
gem "uglifier", "4.1.8"
gem "uglifier", "4.1.19"
# Configuration
......@@ -56,33 +56,33 @@ gem "rack-cors", "1.0.2", require: "rack/cors"
# CSS
gem "autoprefixer-rails", "8.2.0"
gem "autoprefixer-rails", "8.6.5"
gem "bootstrap-sass", "3.3.7"
gem "bootstrap-switch-rails", "3.3.3"
gem "compass-rails", "3.0.2"
gem "bootstrap-switch-rails", "3.3.4"
gem "compass-rails", "3.1.0"
gem "sass-rails", "5.0.7"
gem "sprockets-rails", "3.2.1"
# Database
group :mysql, optional: true do
gem "mysql2", "0.5.0"
gem "mysql2", "0.5.2"
end
group :postgresql, optional: true do
gem "pg", "1.0.0"
gem "pg", "1.1.3"
end
gem "activerecord-import", "0.22.0"
gem "activerecord-import", "0.27.0"
# File uploading
gem "carrierwave", "1.2.2"
gem "fog-aws", "2.0.1"
gem "mini_magick", "4.8.0"
gem "carrierwave", "1.2.3"
gem "fog-aws", "3.3.0"
gem "mini_magick", "4.9.2"
# GUID generation
gem "uuid", "2.3.8"
gem "uuid", "2.3.9"
# Icons
......@@ -91,16 +91,16 @@ gem "entypo-rails", "3.0.0"
# JavaScript
gem "handlebars_assets", "0.23.2"
gem "jquery-rails", "4.3.1"
gem "js-routes", "1.4.3"
gem "jquery-rails", "4.3.3"
gem "js-routes", "1.4.4"
gem "js_image_paths", "0.1.1"
source "https://rails-assets.org" do
gem "rails-assets-jquery", "3.2.1" # Should be kept in sync with jquery-rails
gem "rails-assets-jquery", "3.3.1" # Should be kept in sync with jquery-rails
gem "rails-assets-jquery.ui", "1.11.4"
gem "rails-assets-highlightjs", "9.12.0"
gem "rails-assets-markdown-it", "8.4.1"
gem "rails-assets-markdown-it", "8.4.2"
gem "rails-assets-markdown-it-hashtag", "0.4.0"
gem "rails-assets-markdown-it-diaspora-mention", "1.2.0"
gem "rails-assets-markdown-it-sanitizer", "0.4.3"
......@@ -115,12 +115,12 @@ source "https://rails-assets.org" do
# jQuery plugins
gem "rails-assets-autosize", "4.0.1"
gem "rails-assets-autosize", "4.0.2"
gem "rails-assets-blueimp-gallery", "2.33.0"
gem "rails-assets-jquery.are-you-sure", "1.9.0"
gem "rails-assets-jquery-placeholder", "2.3.1"
gem "rails-assets-jquery-textchange", "0.2.3"
gem "rails-assets-utatti-perfect-scrollbar", "1.3.0"
gem "rails-assets-utatti-perfect-scrollbar", "1.4.0"
end
gem "markdown-it-html5-embed", "1.0.0"
......@@ -129,7 +129,7 @@ gem "markdown-it-html5-embed", "1.0.0"
gem "http_accept_language", "2.1.1"
gem "i18n-inflector-rails", "1.0.7"
gem "rails-i18n", "5.1.1"
gem "rails-i18n", "5.1.2"
# Mail
......@@ -152,7 +152,7 @@ gem "string-direction", "1.2.1"
# Security Headers
gem "secure_headers", "5.0.5"
gem "secure_headers", "6.0.0"
# Services
......@@ -175,20 +175,20 @@ gem "rails-assets-diaspora_jsxc", "0.1.5.develop.7", source: "https://rails-asse
# Tags
gem "acts-as-taggable-on", "5.0.0"
gem "acts-as-taggable-on", "6.0.0"
# URIs and HTTP
gem "addressable", "2.5.2", require: "addressable/uri"
gem "faraday", "0.12.2" # also update User-Agent in OpenID specs
gem "faraday", "0.15.3"
gem "faraday_middleware", "0.12.2"
gem "faraday-cookie_jar", "0.0.6"
gem "typhoeus", "1.3.0"
gem "typhoeus", "1.3.1"
# Views
gem "gon", "6.2.0"
gem "hamlit", "2.8.8"
gem "gon", "6.2.1"
gem "hamlit", "2.9.1"
gem "mobile-fu", "1.4.0"
gem "rails-timeago", "2.16.0"
gem "will_paginate", "3.1.6"
......@@ -234,26 +234,25 @@ group :production do # we don"t install these on travis to speed up test runs
# Third party asset hosting
gem "asset_sync", "2.4.0", require: false
gem "asset_sync", "2.5.0", require: false
end
group :development do
# Automatic test runs
gem "guard", "2.14.2", require: false
gem "guard-cucumber", "2.1.2", require: false
gem "guard", "2.15.0", require: false
gem "guard-rspec", "4.7.3", require: false
gem "guard-rubocop", "1.3.0", require: false
gem "rb-fsevent", "0.10.3", require: false
gem "rb-inotify", "0.9.10", require: false
# Linters
gem "haml_lint", "0.27.0", require: false
gem "haml_lint", "0.28.0", require: false
gem "pronto", "0.9.5", require: false
gem "pronto-eslint", "0.9.1", require: false
gem "pronto-haml", "0.9.0", require: false
gem "pronto-rubocop", "0.9.0", require: false
gem "pronto-rubocop", "0.9.1", require: false
gem "pronto-scss", "0.9.1", require: false
gem "rubocop", "0.54.0", require: false
gem "rubocop", "0.60.0", require: false
# Preloading environment
......@@ -266,7 +265,7 @@ group :development do
gem "pry-byebug"
# test coverage
gem "simplecov", "0.14.1", require: false
gem "simplecov", "0.16.1", require: false
gem "turbo_dev_assets", "0.0.2"
end
......@@ -275,15 +274,15 @@ group :test do
# RSpec (unit tests, some integration tests)
gem "fixture_builder", "0.5.2.rc3"
gem "fuubar", "2.3.1"
gem "fuubar", "2.3.2"
gem "json-schema-rspec", "0.0.4"
gem "rspec-json_expectations", "~> 2.1"
# Cucumber (integration tests)
gem "capybara", "2.18.0"
gem "database_cleaner", "1.6.2"
gem "poltergeist", "1.17.0"
gem "capybara", "3.11.1"
gem "database_cleaner", "1.7.0"
gem "poltergeist", "1.18.1"
gem "cucumber-api-steps", "0.14", require: false
......@@ -292,25 +291,25 @@ group :test do
gem "factory_girl_rails", "4.8.0"
gem "shoulda-matchers", "3.1.2"
gem "timecop", "0.9.1"
gem "webmock", "3.3.0", require: false
gem "webmock", "3.4.2", require: false
gem "diaspora_federation-test", "0.2.5"
# Coverage
gem "coveralls", "0.8.21", require: false
gem "coveralls", "0.8.22", require: false
end
group :development, :test do
# RSpec (unit tests, some integration tests)
gem "rspec-rails", "3.7.2"
gem "rspec-rails", "3.8.1"
# Cucumber (integration tests)
gem "cucumber-rails", "1.5.0", require: false
gem "cucumber-rails", "1.6.0", require: false
# Jasmine (client side application tests (JS))
gem "jasmine", "3.1.0"
gem "jasmine", "3.3.0"
gem "jasmine-jquery-rails", "2.0.3"
gem "rails-assets-jasmine-ajax", "3.3.1", source: "https://rails-assets.org"
gem "rails-assets-jasmine-ajax", "3.4.0", source: "https://rails-assets.org"
gem "sinon-rails", "1.15.0"
# For `assigns` in controller specs
......
......@@ -37,15 +37,15 @@ GEM
activemodel (= 5.1.6)
activesupport (= 5.1.6)
arel (~> 8.0)
activerecord-import (0.22.0)
activerecord-import (0.27.0)
activerecord (>= 3.2)
activesupport (5.1.6)
concurrent-ruby (~> 1.0, >= 1.0.2)
i18n (>= 0.7, < 2)
minitest (~> 5.1)
tzinfo (~> 1.1)
acts-as-taggable-on (5.0.0)
activerecord (>= 4.2.8)
acts-as-taggable-on (6.0.0)
activerecord (~> 5.0)
acts_as_api (1.0.1)
activemodel (>= 3.0.0)
activesupport (>= 3.0.0)
......@@ -54,32 +54,34 @@ GEM
public_suffix (>= 2.0.2, < 4.0)
aes_key_wrap (1.0.1)
arel (8.0.0)
asset_sync (2.4.0)
asset_sync (2.5.0)
activemodel (>= 4.1.0)
fog-core
mime-types (>= 2.99)
unf
ast (2.4.0)
attr_required (1.0.1)
autoprefixer-rails (8.2.0)
autoprefixer-rails (8.6.5)
execjs
bcrypt (3.1.11)
bindata (2.4.3)
backports (3.11.4)
bcrypt (3.1.12)
bindata (2.4.4)
bootstrap-sass (3.3.7)
autoprefixer-rails (>= 5.2.1)
sass (>= 3.3.4)
bootstrap-switch-rails (3.3.3)
bootstrap-switch-rails (3.3.4)
buftok (0.2.0)
builder (3.2.3)
byebug (10.0.2)
capybara (2.18.0)
capybara (3.11.1)
addressable
mini_mime (>= 0.1.3)
nokogiri (>= 1.3.3)
rack (>= 1.0.0)
rack-test (>= 0.5.4)
xpath (>= 2.0, < 4.0)
carrierwave (1.2.2)
nokogiri (~> 1.8)
rack (>= 1.6.0)
rack-test (>= 0.6.3)
regexp_parser (~> 1.2)
xpath (~> 3.2)
carrierwave (1.2.3)
activemodel (>= 4.0.0)
activesupport (>= 4.0.0)
mime-types (>= 1.16)
......@@ -119,44 +121,49 @@ GEM
sass (>= 3.3.0, < 3.5)
compass-import-once (1.0.5)
sass (>= 3.2, < 3.5)
compass-rails (3.0.2)
compass-rails (3.1.0)
compass (~> 1.0.0)
sass-rails (< 5.1)
sprockets (< 4.0)
concurrent-ruby (1.0.5)
concurrent-ruby (1.1.3)
configurate (0.3.1)
connection_pool (2.2.1)
coveralls (0.8.21)
connection_pool (2.2.2)
coveralls (0.8.22)
json (>= 1.8, < 3)
simplecov (~> 0.14.1)
simplecov (~> 0.16.1)
term-ansicolor (~> 1.3)
thor (~> 0.19.4)
tins (~> 1.6)
crack (0.4.3)
safe_yaml (~> 1.0.0)
crass (1.0.3)
cucumber (2.99.0)
crass (1.0.4)
cucumber (3.1.2)
builder (>= 2.1.2)
cucumber-core (~> 1.5.0)
cucumber-core (~> 3.2.0)
cucumber-expressions (~> 6.0.1)
cucumber-wire (~> 0.0.1)
diff-lcs (>= 1.1.3)
gherkin (~> 4.0)
diff-lcs (~> 1.3)
gherkin (~> 5.1.0)
multi_json (>= 1.7.5, < 2.0)
multi_test (>= 0.1.2)
cucumber-api-steps (0.14.0)
cucumber (>= 2.0.2)
jsonpath (>= 0.1.2)
cucumber-core (1.5.0)
gherkin (~> 4.0)
cucumber-rails (1.5.0)
capybara (>= 1.1.2, < 3)
cucumber (>= 1.3.8, < 4)
cucumber-core (3.2.1)
backports (>= 3.8.0)
cucumber-tag_expressions (~> 1.1.0)
gherkin (~> 5.0)
cucumber-expressions (6.0.1)
cucumber-rails (1.6.0)
capybara (>= 1.1.2, < 4)
cucumber (>= 3.0.2, < 4)
mime-types (>= 1.17, < 4)
nokogiri (~> 1.5)
railties (>= 4, < 5.2)
nokogiri (~> 1.8)
railties (>= 4, < 6)
cucumber-tag_expressions (1.1.1)
cucumber-wire (0.0.1)
database_cleaner (1.6.2)
devise (4.4.3)
database_cleaner (1.7.0)
devise (4.5.0)
bcrypt (~> 3.0)
orm_adapter (~> 0.1)
railties (>= 4.1.0, < 6.0)
......@@ -181,8 +188,8 @@ GEM
fabrication (~> 2.16)
uuid (~> 2.3, >= 2.3.8)
diff-lcs (1.3)
docile (1.1.5)
domain_name (0.5.20170404)
docile (1.3.1)
domain_name (0.5.20180417)
unf (>= 0.0.5, < 1.0.0)
entypo-rails (3.0.0)
railties (>= 4.1, < 6)
......@@ -192,7 +199,7 @@ GEM
execjs
multi_json (>= 1.3)
rake
et-orbi (1.1.0)
et-orbi (1.1.6)
tzinfo
ethon (0.11.0)
ffi (>= 1.3.0)
......@@ -210,7 +217,7 @@ GEM
factory_girl_rails (4.8.0)
factory_girl (~> 4.8.0)
railties (>= 3.0.0)
faraday (0.12.2)
faraday (0.15.3)
multipart-post (>= 1.2, < 3)
faraday-cookie_jar (0.0.6)
faraday (>= 0.7.4)
......@@ -222,37 +229,41 @@ GEM
activerecord (>= 2)
activesupport (>= 2)
hashdiff
fog-aws (2.0.1)
fog-core (~> 1.38)
fog-json (~> 1.0)
fog-aws (3.3.0)
fog-core (~> 2.1)
fog-json (~> 1.1)
fog-xml (~> 0.1)
ipaddress (~> 0.8)
fog-core (1.45.0)
fog-core (2.1.2)
builder
excon (~> 0.58)
formatador (~> 0.2)
fog-json (1.0.2)
fog-core (~> 1.0)
mime-types
fog-json (1.2.0)
fog-core
multi_json (~> 1.10)
fog-xml (0.1.3)
fog-core
nokogiri (>= 1.5.11, < 2.0.0)
formatador (0.2.5)
fuubar (2.3.1)
fugit (1.1.6)
et-orbi (~> 1.1, >= 1.1.6)
raabro (~> 1.1)
fuubar (2.3.2)
rspec-core (~> 3.0)
ruby-progressbar (~> 1.4)
get_process_mem (0.2.1)
gherkin (4.1.3)
gitlab (4.3.0)
httparty
terminal-table
get_process_mem (0.2.3)
gherkin (5.1.0)
gitlab (4.7.0)
httparty (>= 0.14.0)
terminal-table (>= 1.5.1)
globalid (0.4.1)
activesupport (>= 4.2.0)
gon (6.2.0)
gon (6.2.1)
actionpack (>= 3.0)
multi_json
request_store (>= 1.0)
guard (2.14.2)
guard (2.15.0)
formatador (>= 0.2.4)
listen (>= 2.7, < 4.0)
lumberjack (>= 1.0.12, < 2.0)
......@@ -262,10 +273,6 @@ GEM
shellany (~> 0.0)
thor (>= 0.18.1)
guard-compat (1.2.1)
guard-cucumber (2.1.2)
cucumber (~> 2.0)
guard-compat (~> 1.0)
nenv (~> 0.1)
guard-rspec (4.7.3)
guard (~> 2.1)
guard-compat (~> 1.1)
......@@ -276,13 +283,13 @@ GEM
haml (5.0.4)
temple (>= 0.8.0)
tilt
haml_lint (0.27.0)
haml_lint (0.28.0)
haml (>= 4.0, < 5.1)
rainbow
rake (>= 10, < 13)
rubocop (>= 0.50.0)
sysexits (~> 1.1)
hamlit (2.8.8)
hamlit (2.9.1)
temple (>= 0.8.0)
thor
tilt
......@@ -292,21 +299,21 @@ GEM
tilt (>= 1.2)
hashdiff (0.3.7)
hashie (3.5.7)
hitimes (1.2.6)
http (3.0.0)
http (3.3.0)
addressable (~> 2.3)
http-cookie (~> 1.0)
http-form_data (>= 2.0.0.pre.pre2, < 3)
http-form_data (~> 2.0)
http_parser.rb (~> 0.6.0)
http-cookie (1.0.3)
domain_name (~> 0.5)
http-form_data (2.1.0)
http-form_data (2.1.1)
http_accept_language (2.1.1)
http_parser.rb (0.6.0)
httparty (0.16.2)
httparty (0.16.3)
mime-types (~> 3.0)
multi_xml (>= 0.5.2)
httpclient (2.8.3)
i18n (1.1.0)
i18n (1.1.1)
concurrent-ruby (~> 1.0)
i18n-inflector (2.6.7)
i18n (>= 0.4.1)
......@@ -315,18 +322,19 @@ GEM
i18n-inflector (~> 2.6)
railties (>= 3.0.0)
ipaddress (0.8.3)
jasmine (3.1.0)
jasmine-core (= 3.1.0)
jaro_winkler (1.5.1)
jasmine (3.3.0)
jasmine-core (~> 3.3.0)
phantomjs
rack (>= 1.2.1)
rake
jasmine-core (3.1.0)
jasmine-core (3.3.0)
jasmine-jquery-rails (2.0.3)
jquery-rails (4.3.1)
jquery-rails (4.3.3)
rails-dom-testing (>= 1, < 3)
railties (>= 4.2.0)
thor (>= 0.14, < 2.0)
js-routes (1.4.3)
js-routes (1.4.4)
railties (>= 3.2)
sprockets-rails
js_image_paths (0.1.1)
......@@ -337,15 +345,15 @@ GEM
activesupport
aes_key_wrap
bindata
json-schema (2.8.0)
json-schema (2.8.1)
addressable (>= 2.4)
json-schema-rspec (0.0.4)
json-schema (~> 2.5)
rspec
jsonpath (0.8.11)
jsonpath (0.9.6)
multi_json
to_regexp (~> 0.2.1)
jwt (1.5.6)
jwt (2.1.0)
kgio (2.11.2)
kostya-sigar (2.0.4)
leaflet-rails (1.3.1)
......@@ -360,23 +368,23 @@ GEM
multi_json (~> 1.10)
logging-rails (0.6.0)
logging (>= 1.8)
loofah (2.2.2)
loofah (2.2.3)
crass (~> 1.0.2)
nokogiri (>= 1.5.9)
lumberjack (1.0.13)
macaddr (1.7.1)
systemu (~> 2.6.2)
mail (2.7.0)
mail (2.7.1)
mini_mime (>= 0.1.1)
markdown-it-html5-embed (1.0.0)
markerb (1.1.0)
memoizable (0.4.2)
thread_safe (~> 0.3, >= 0.3.1)
method_source (0.9.0)
mime-types (3.1)
method_source (0.9.2)
mime-types (3.2.2)
mime-types-data (~> 3.2015)
mime-types-data (3.2016.0521)
mini_magick (4.8.0)
mime-types-data (3.2018.0812)
mini_magick (4.9.2)
mini_mime (1.0.1)
mini_portile2 (2.3.0)
minitest (5.11.3)
......@@ -387,23 +395,23 @@ GEM
multi_test (0.1.2)
multi_xml (0.6.0)
multipart-post (2.0.0)
mysql2 (0.5.0)
mysql2 (0.5.2)
naught (1.1.0)
nenv (0.3.0)
nio4r (2.3.0)
nio4r (2.3.1)
nokogiri (1.8.5)
mini_portile2 (~> 2.3.0)
notiffany (0.1.1)
nenv (~> 0.1)
shellany (~> 0.0)
oauth (0.5.4)
oauth2 (1.4.0)
faraday (>= 0.8, < 0.13)
jwt (~> 1.0)
oauth2 (1.4.1)
faraday (>= 0.8, < 0.16.0)
jwt (>= 1.0, < 3.0)
multi_json (~> 1.3)
multi_xml (~> 0.5)
rack (>= 1.2, < 3)
octokit (4.8.0)
octokit (4.13.0)
sawyer (~> 0.8.0, >= 0.5.3)
omniauth (1.8.1)
hashie (>= 3.4.6, < 3.6.0)
......@@ -437,15 +445,15 @@ GEM
webfinger (>= 1.0.1)
orm_adapter (0.5.0)
parallel (1.12.1)
parser (2.5.0.5)
parser (2.5.3.0)
ast (~> 2.4.0)
pg (1.0.0)
pg (1.1.3)
phantomjs (2.1.1.0)
poltergeist (1.17.0)
capybara (~> 2.1)
poltergeist (1.18.1)
capybara (>= 2.1, < 4)
cliver (~> 0.3.1)
websocket-driver (>= 0.2.0)
powerpack (0.1.1)
powerpack (0.1.2)
pronto (0.9.5)
gitlab (~> 4.0, >= 4.0.0)
httparty (>= 0.13.7)
......@@ -459,19 +467,20 @@ GEM
pronto-haml (0.9.0)
haml_lint (~> 0.23)
pronto (~> 0.9.0)
pronto-rubocop (0.9.0)
pronto-rubocop (0.9.1)
pronto (~> 0.9.0)
rubocop (~> 0.38, >= 0.35.0)
rubocop (~> 0.50, >= 0.49.1)
pronto-scss (0.9.1)
pronto (~> 0.9.0)
scss_lint (~> 0.43, >= 0.43.0)
pry (0.11.3)
pry (0.12.2)
coderay (~> 1.1.0)
method_source (~> 0.9.0)
pry-byebug (3.6.0)
byebug (~> 10.0)
pry (~> 0.10)
public_suffix (3.0.3)
raabro (1.1.6)
rack (2.0.6)
rack-cors (1.0.2)
rack-google-analytics (1.2.0)
......@@ -479,19 +488,19 @@ GEM
activesupport
rack-mobile-detect (0.4.0)
rack
rack-oauth2 (1.9.2)
rack-oauth2 (1.9.3)
activesupport
attr_required
httpclient
json-jwt (>= 1.9.0)
rack
rack-piwik (0.3.0)
rack-protection (2.0.1)
rack-protection (2.0.4)
rack
rack-rewrite (1.5.1)
rack-ssl (1.4.1)
rack
rack-test (1.0.0)
rack-test (1.1.0)
rack (>= 1.0, < 3)
rails (5.1.6)
actioncable (= 5.1.6)
......@@ -505,7 +514,7 @@ GEM
bundler (>= 1.3.0)
railties (= 5.1.6)
sprockets-rails (>= 2.0.0)
rails-assets-autosize (4.0.1)