Commit 55f40a2b authored by Jonne Haß's avatar Jonne Haß
Browse files

update to rails 4

parent 58927d1a
source 'https://rubygems.org'
gem 'rails', '3.2.19'
gem 'rails', '4.0.3'
# Legacy Rails features, remove me!
# caches_page
gem 'actionpack-action_caching'
gem 'actionpack-page_caching'
# Appserver
......@@ -25,6 +31,10 @@ gem 'galetahub-simple_captcha', '0.1.5', :require => 'simple_captcha'
gem 'sidekiq', '2.17.7'
gem 'sinatra', '1.3.3'
# Compression
gem 'uglifier', '2.5.0'
# Configuration
gem 'configurate', '0.0.8'
......@@ -33,6 +43,12 @@ gem 'configurate', '0.0.8'
gem 'rack-cors', '0.2.9', :require => 'rack/cors'
# CSS
gem 'bootstrap-sass', '2.3.2.2'
gem 'compass-rails', '1.1.7'
gem 'sass-rails', '4.0.1'
# Database
ENV['DB'] ||= 'mysql'
......@@ -40,7 +56,7 @@ ENV['DB'] ||= 'mysql'
gem 'mysql2', '0.3.16' if ENV['DB'] == 'all' || ENV['DB'] == 'mysql'
gem 'pg', '0.17.1' if ENV['DB'] == 'all' || ENV['DB'] == 'postgres'
gem 'activerecord-import', '0.3.1'
gem 'activerecord-import', '0.4.1'
gem 'foreigner', '1.6.1'
# File uploading
......@@ -53,11 +69,21 @@ gem 'remotipart', '1.2.1'
# GUID generation
gem 'uuid', '2.3.7'
# Icons
gem 'entypo-rails', '2.2.1'
# JavaScript
gem 'backbone-on-rails', '1.1.1'
gem 'handlebars_assets', '0.12.0'
gem 'jquery-rails', '3.0.4'
# Localization
gem 'http_accept_language', '1.0.2'
gem 'i18n-inflector-rails', '1.0.7'
gem 'rails-i18n', '0.7.4'
gem 'rails-i18n', '4.0.1'
# Mail
......@@ -74,10 +100,6 @@ gem 'ruby-oembed', '0.8.9'
gem 'opengraph_parser', '0.2.3'
# Please remove when migrating to Rails 4
gem 'strong_parameters', '0.2.3'
# Services
gem 'omniauth', '1.2.1'
......@@ -110,42 +132,19 @@ gem 'rails-timeago', '2.4.0'
# https://github.com/rubyzip/rubyzip#important-note
gem 'zip-zip'
### GROUPS ####
group :assets do
# Icons
gem 'entypo-rails', '2.2.1'
# CSS
gem 'bootstrap-sass', '2.2.2.0'
gem 'compass-rails', '1.1.7'
gem 'sass-rails', '3.2.6'
# Compression
# Windows and OSX have an execjs compatible runtime built-in, Linux users should
# install Node.js or use 'therubyracer'.
#
# See https://github.com/sstephenson/execjs#readme for more supported runtimes
gem 'uglifier', '2.5.0'
# JavaScript
gem 'backbone-on-rails', '1.1.1'
gem 'handlebars_assets', '0.12.0'
gem 'jquery-rails', '3.0.4'
# Windows and OSX have an execjs compatible runtime built-in, Linux users should
# install Node.js or use 'therubyracer'.
#
# See https://github.com/sstephenson/execjs#readme for more supported runtimes
# gem 'therubyracer', :platform => :ruby
end
# gem 'therubyracer', :platform => :ruby
group :production do # we don't install these on travis to speed up test runs
# Administration
gem 'rails_admin', '0.4.9'
gem 'rails_admin', '0.6.1'
# Analytics
......@@ -213,6 +212,6 @@ group :development, :test do
gem 'cucumber-rails', '1.4.1', :require => false
# Jasmine (client side application tests (JS))
gem 'jasmine', '1.3.2'
gem 'jasmine', '2.0.0'
gem 'sinon-rails', '1.9.0'
end
GEM
remote: https://rubygems.org/
specs:
actionmailer (3.2.19)
actionpack (= 3.2.19)
actionmailer (4.0.3)
actionpack (= 4.0.3)
mail (~> 2.5.4)
actionpack (3.2.19)
activemodel (= 3.2.19)
activesupport (= 3.2.19)
builder (~> 3.0.0)
actionpack (4.0.3)
activesupport (= 4.0.3)
builder (~> 3.1.0)
erubis (~> 2.7.0)
journey (~> 1.0.4)
rack (~> 1.4.5)
rack-cache (~> 1.2)
rack-test (~> 0.6.1)
sprockets (~> 2.2.1)
activemodel (3.2.19)
activesupport (= 3.2.19)
builder (~> 3.0.0)
activerecord (3.2.19)
activemodel (= 3.2.19)
activesupport (= 3.2.19)
arel (~> 3.0.2)
tzinfo (~> 0.3.29)
activerecord-import (0.3.1)
activerecord (~> 3.0)
activeresource (3.2.19)
activemodel (= 3.2.19)
activesupport (= 3.2.19)
activesupport (3.2.19)
rack (~> 1.5.2)
rack-test (~> 0.6.2)
actionpack-action_caching (1.1.1)
actionpack (>= 4.0.0, < 5.0)
actionpack-page_caching (1.0.2)
actionpack (>= 4.0.0, < 5)
activemodel (4.0.3)
activesupport (= 4.0.3)
builder (~> 3.1.0)
activerecord (4.0.3)
activemodel (= 4.0.3)
activerecord-deprecated_finders (~> 1.0.2)
activesupport (= 4.0.3)
arel (~> 4.0.0)
activerecord-deprecated_finders (1.0.3)
activerecord-import (0.4.1)
activerecord (>= 3.0)
activeresource (4.0.0)
activemodel (~> 4.0)
activesupport (~> 4.0)
rails-observers (~> 0.1.1)
activesupport (4.0.3)
i18n (~> 0.6, >= 0.6.4)
multi_json (~> 1.0)
minitest (~> 4.2)
multi_json (~> 1.3)
thread_safe (~> 0.1)
tzinfo (~> 0.3.37)
acts-as-taggable-on (3.2.6)
activerecord (>= 3, < 5)
acts_as_api (0.4.2)
......@@ -37,7 +42,7 @@ GEM
activesupport (>= 3.0.0)
rack (>= 1.1.0)
addressable (2.3.6)
arel (3.0.3)
arel (4.0.2)
asset_sync (1.0.0)
activemodel
fog (>= 1.8.0)
......@@ -51,9 +56,9 @@ GEM
jquery-rails
railties
bcrypt (3.1.7)
bootstrap-sass (2.2.2.0)
bootstrap-sass (2.3.2.2)
sass (~> 3.2)
builder (3.0.4)
builder (3.1.4)
capybara (2.2.1)
mime-types (>= 1.16)
nokogiri (>= 1.3.3)
......@@ -71,30 +76,30 @@ GEM
ffi (~> 1.0, >= 1.0.11)
chunky_png (1.3.1)
coderay (1.1.0)
coffee-rails (3.2.2)
coffee-rails (4.0.1)
coffee-script (>= 2.2.0)
railties (~> 3.2.0)
railties (>= 4.0.0, < 5.0)
coffee-script (2.2.0)
coffee-script-source
execjs
coffee-script-source (1.7.0)
compass (0.12.6)
coffee-script-source (1.6.3)
compass (0.12.3)
chunky_png (~> 1.2)
fssm (>= 0.2.7)
sass (~> 3.2.19)
sass (= 3.2.14)
compass-rails (1.1.7)
compass (>= 0.12.2)
sprockets (<= 2.11.0)
configurate (0.0.8)
connection_pool (2.0.0)
crack (0.4.1)
safe_yaml (~> 0.9.0)
connection_pool (1.2.0)
crack (0.4.2)
safe_yaml (~> 1.0.0)
cucumber (1.3.15)
builder (>= 2.1.2)
diff-lcs (>= 1.1.3)
gherkin (~> 2.12)
multi_json (>= 1.7.5, < 2.0)
multi_test (>= 0.1.1)
multi_test (>= 0.0.2)
cucumber-rails (1.4.1)
capybara (>= 1.1.2, < 3)
cucumber (>= 1.3.8, < 2)
......@@ -125,10 +130,11 @@ GEM
entypo-rails (2.2.1)
railties (>= 3.1, <= 5)
erubis (2.7.0)
ethon (0.7.0)
ethon (0.7.1)
ffi (>= 1.3.0)
excon (0.34.0)
execjs (2.1.0)
excon (0.39.0)
execjs (1.4.0)
multi_json (~> 1.0)
factory_girl (4.4.0)
activesupport (>= 3.0.0)
factory_girl_rails (4.4.1)
......@@ -148,19 +154,20 @@ GEM
fog-json
ipaddress (~> 0.5)
nokogiri (~> 1.5, >= 1.5.11)
fog-brightbox (0.0.2)
fog-core
fog-brightbox (0.1.1)
fog-core (~> 1.22)
fog-json
fog-core (1.22.0)
inflecto
fog-core (1.23.0)
builder
excon (~> 0.33)
excon (~> 0.38)
formatador (~> 0.2)
mime-types
net-scp (~> 1.1)
net-ssh (>= 2.1.3)
fog-json (1.0.0)
multi_json (~> 1.0)
font-awesome-rails (3.2.1.2)
font-awesome-rails (4.0.3.1)
railties (>= 3.2, < 5.0)
foreigner (1.6.1)
activerecord (>= 3.0.0)
......@@ -177,9 +184,9 @@ GEM
gon (5.0.4)
actionpack (>= 2.3.0)
json
guard (2.6.1)
guard (2.2.5)
formatador (>= 0.2.4)
listen (~> 2.7)
listen (~> 2.1)
lumberjack (~> 1.0)
pry (>= 0.9.12)
thor (>= 0.18.1)
......@@ -199,43 +206,44 @@ GEM
execjs (>= 1.2.9)
sprockets (>= 2.0.3)
tilt
hashie (2.1.1)
hashie (2.1.2)
hike (1.2.3)
http_accept_language (1.0.2)
i18n (0.6.9)
httpauth (0.2.0)
i18n (0.6.11)
i18n-inflector (2.6.7)
i18n (>= 0.4.1)
i18n-inflector-rails (1.0.7)
actionpack (>= 3.0.0)
i18n-inflector (~> 2.6)
railties (>= 3.0.0)
inflecto (0.0.2)
ipaddress (0.8.0)
jasmine (1.3.2)
jasmine-core (~> 1.3.1)
rack (~> 1.0)
rspec (>= 1.3.1)
selenium-webdriver (>= 0.1.3)
jasmine-core (1.3.1)
journey (1.0.4)
jasmine (2.0.0)
jasmine-core (~> 2.0.0)
phantomjs
rack (>= 1.2.1)
rake
jasmine-core (2.0.0)
jquery-rails (3.0.4)
railties (>= 3.0, < 5.0)
thor (>= 0.14, < 2.0)
jquery-ui-rails (3.0.1)
jquery-rails
railties (>= 3.1.0)
jquery-ui-rails (4.2.0)
railties (>= 3.2.16)
json (1.8.1)
jwt (1.0.0)
jwt (0.1.10)
multi_json (>= 1.5)
kaminari (0.15.1)
actionpack (>= 3.0.0)
activesupport (>= 3.0.0)
kgio (2.9.2)
listen (2.7.5)
listen (2.4.0)
celluloid (>= 0.15.2)
rb-fsevent (>= 0.9.3)
rb-inotify (>= 0.9)
lumberjack (1.0.6)
macaddr (1.6.1)
systemu (~> 2.5.0)
lumberjack (1.0.4)
macaddr (1.7.1)
systemu (~> 2.6.2)
mail (2.5.4)
mime-types (~> 1.16)
treetop (~> 1.4.8)
......@@ -247,12 +255,12 @@ GEM
mini_magick (3.7.0)
subexec (~> 0.2.1)
mini_portile (0.5.3)
minitest (4.7.5)
mobile-fu (1.2.2)
rack-mobile-detect
rails
multi_json (1.10.1)
multi_test (0.1.1)
multi_xml (0.5.5)
multi_test (0.0.3)
multipart-post (1.2.0)
mysql2 (0.3.16)
nested_form (0.3.2)
......@@ -262,11 +270,11 @@ GEM
nokogiri (1.6.1)
mini_portile (~> 0.5.0)
oauth (0.4.7)
oauth2 (0.9.4)
faraday (>= 0.8, < 0.10)
jwt (~> 1.0)
multi_json (~> 1.3)
multi_xml (~> 0.5)
oauth2 (0.8.1)
faraday (~> 0.8)
httpauth (~> 0.1)
jwt (~> 0.1.4)
multi_json (~> 1.0)
rack (~> 1.2)
omniauth (1.2.1)
hashie (>= 1.2, < 3)
......@@ -276,11 +284,9 @@ GEM
omniauth-oauth (1.0.1)
oauth
omniauth (~> 1.0)
omniauth-oauth2 (1.1.2)
faraday (>= 0.8, < 0.10)
multi_json (~> 1.3)
oauth2 (~> 0.9.3)
omniauth (~> 1.2)
omniauth-oauth2 (1.1.1)
oauth2 (~> 0.8.0)
omniauth (~> 1.0)
omniauth-tumblr (1.1)
omniauth-oauth (~> 1.0)
omniauth-twitter (1.0.1)
......@@ -292,14 +298,13 @@ GEM
addressable
nokogiri
orm_adapter (0.5.0)
polyglot (0.3.5)
pry (0.9.12.6)
phantomjs (1.9.2.1)
polyglot (0.3.4)
pry (0.9.12.4)
coderay (~> 1.0)
method_source (~> 0.8)
slop (~> 3.4)
rack (1.4.5)
rack-cache (1.2)
rack (>= 0.4)
rack (1.5.2)
rack-cors (0.2.9)
rack-google-analytics (0.14.0)
actionpack
......@@ -317,50 +322,48 @@ GEM
rack
rack-test (0.6.2)
rack (>= 1.0)
rails (3.2.19)
actionmailer (= 3.2.19)
actionpack (= 3.2.19)
activerecord (= 3.2.19)
activeresource (= 3.2.19)
activesupport (= 3.2.19)
bundler (~> 1.0)
railties (= 3.2.19)
rails-i18n (0.7.4)
i18n (~> 0.5)
rails (4.0.3)
actionmailer (= 4.0.3)
actionpack (= 4.0.3)
activerecord (= 4.0.3)
activesupport (= 4.0.3)
bundler (>= 1.3.0, < 2.0)
railties (= 4.0.3)
sprockets-rails (~> 2.0.0)
rails-i18n (4.0.1)
i18n (~> 0.6)
rails (~> 4.0)
rails-observers (0.1.2)
activemodel (~> 4.0)
rails-timeago (2.4.0)
actionpack (>= 3.1)
activesupport (>= 3.1)
rails_admin (0.4.9)
bootstrap-sass (~> 2.2)
builder (~> 3.0)
coffee-rails (>= 3.1, < 5)
font-awesome-rails (~> 3.0)
rails_admin (0.6.1)
builder (~> 3.1)
coffee-rails (~> 4.0)
font-awesome-rails (>= 3.0)
haml (~> 4.0)
jquery-rails (>= 2.1, < 4)
jquery-ui-rails (~> 3.0)
jquery-rails (~> 3.0)
jquery-ui-rails (~> 4.0)
kaminari (~> 0.14)
nested_form (~> 0.3)
rack-pjax (~> 0.6)
rails (~> 3.1)
rack-pjax (~> 0.7)
rails (~> 4.0)
remotipart (~> 1.0)
safe_yaml (~> 0.6)
sass-rails (~> 3.1)
safe_yaml (~> 1.0)
sass-rails (~> 4.0)
rails_autolink (1.1.5)
rails (> 3.1)
railties (3.2.19)
actionpack (= 3.2.19)
activesupport (= 3.2.19)
rack-ssl (~> 1.3.2)
railties (4.0.3)
actionpack (= 4.0.3)
activesupport (= 4.0.3)
rake (>= 0.8.7)
rdoc (~> 3.4)
thor (>= 0.14.6, < 2.0)
thor (>= 0.18.1, < 2.0)
raindrops (0.13.0)
rake (10.3.2)
rb-fsevent (0.9.4)
rb-inotify (0.9.4)
ffi (>= 0.5.0)
rdoc (3.12.2)
json (~> 1.4)
redcarpet (3.1.2)
redis (3.1.0)
redis-namespace (1.5.1)
......@@ -388,13 +391,13 @@ GEM
rspec-mocks (~> 2.14.0)
ruby-oembed (0.8.9)
ruby-progressbar (1.5.1)
rubyzip (1.1.4)
safe_yaml (0.9.7)
sass (3.2.19)
sass-rails (3.2.6)
railties (~> 3.2.0)
rubyzip (1.1.0)
safe_yaml (1.0.1)
sass (3.2.14)
sass-rails (4.0.1)
railties (>= 4.0.0, < 5.0)
sass (>= 3.1.10)
tilt (~> 1.3)
sprockets-rails (~> 2.0.0)
selenium-webdriver (2.42.0)
childprocess (>= 0.5.0)
multi_json (~> 1.0)
......@@ -413,20 +416,19 @@ GEM
tilt (~> 1.3, >= 1.3.3)
sinon-rails (1.9.0)
railties (>= 3.1)
slop (3.5.0)
slop (3.4.7)
spork (1.0.0rc4)
sprockets (2.2.2)
sprockets (2.11.0)
hike (~> 1.2)
multi_json (~> 1.0)
rack (~> 1.0)
tilt (~> 1.1, != 1.3.0)
strong_parameters (0.2.3)
actionpack (~> 3.0)
activemodel (~> 3.0)
activesupport (~> 3.0)
railties (~> 3.0)
sprockets-rails (2.0.1)
actionpack (>= 3.0)
activesupport (>= 3.0)
sprockets (~> 2.8)
subexec (0.2.3)
systemu (2.5.2)
systemu (2.6.4)
test_after_commit (0.2.3)
thor (0.19.1)
thread_safe (0.3.4)
......@@ -442,7 +444,7 @@ GEM
simple_oauth (~> 0.2)
typhoeus (0.6.8)
ethon (>= 0.7.0)
tzinfo (0.3.39)
tzinfo (0.3.40)
uglifier (2.5.0)
execjs (>= 0.3.0)
json (>= 1.8.0)
......@@ -452,7 +454,6 @@ GEM
raindrops (~> 0.7)
uuid (2.3.7)
macaddr (~> 1.0)
rack (>= 1.0)
warden (1.2.3)
rack (>= 1.0)
webmock (1.18.0)
......@@ -462,20 +463,22 @@ GEM
will_paginate (3.0.5)
xpath (2.0.0)
nokogiri (~> 1.3)
zip-zip (0.3)
zip-zip (0.2)
rubyzip (>= 1.0.0)
PLATFORMS
ruby
DEPENDENCIES
activerecord-import (= 0.3.1)
actionpack-action_caching
actionpack-page_caching
activerecord-import (= 0.4.1)
acts-as-taggable-on (= 3.2.6)
acts_as_api (= 0.4.2)
addressable (= 2.3.6)
asset_sync (= 1.0.0)
backbone-on-rails (= 1.1.1)
bootstrap-sass (= 2.2.2.0)
bootstrap-sass (= 2.3.2.2)
capybara (= 2.2.1)
carrierwave (= 0.10.0)
compass-rails (= 1.1.7)
......@@ -502,7 +505,7 @@ DEPENDENCIES
handlebars_assets (= 0.12.0)
http_accept_language (= 1.0.2)
i18n-inflector-rails (= 1.0.7)
jasmine (= 1.3.2)
jasmine (= 2.0.0)
jquery-rails (= 3.0.4)
json (= 1.8.1)
markerb (= 1.0.2)
......@@ -523,10 +526,10 @@ DEPENDENCIES
rack-protection (= 1.2)
rack-rewrite (= 1.5.0)
rack-ssl (= 1.3.3)
rails (= 3.2.19)
rails-i18n (= 0.7.4)
rails (= 4.0.3)
rails-i18n (= 4.0.1)
rails-timeago (= 2.4.0)
rails_admin (= 0.4.9)
rails_admin (= 0.6.1)
rails_autolink (= 1.1.5)
rb-fsevent (= 0.9.4)
rb-inotify (= 0.9.4)
......@@ -536,13 +539,12 @@ DEPENDENCIES
rspec-instafail (= 0.2.4)
rspec-rails (= 2.14.2)
ruby-oembed (= 0.8.9)
sass-rails (= 3.2.6)
sass-rails (= 4.0.1)
selenium-webdriver (= 2.42.0)
sidekiq (= 2.17.7)
sinatra (= 1.3.3)
sinon-rails (= 1.9.0)
spork (= 1.0.0rc4)
strong_parameters (= 0.2.3)
test_after_commit (= 0.2.3)
timecop (= 0.7.1)
twitter (= 4.8.1)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment