Commit 379df761 authored by Maxwell Salzberg's avatar Maxwell Salzberg
Browse files

Update to faraday-middleware, as faraday stack has been deprecated.

Hopefully this will make REE happy in Travis
parent ad6151c8
......@@ -134,7 +134,7 @@ gem 'jquery-rails'
# web
gem 'faraday'
gem 'faraday-stack'
gem 'faraday_middleware'
gem 'em-synchrony', '1.0.0', :platforms => :ruby_19
......
......@@ -172,8 +172,8 @@ GEM
addressable (~> 2.2)
multipart-post (~> 1.1)
rack (~> 1.1)
faraday-stack (0.1.5)
faraday (>= 0.6, < 0.8)
faraday_middleware (0.8.7)
faraday (>= 0.7.4, < 0.9)
fastercsv (1.5.4)
fastthread (1.0.7)
ffi (1.0.11)
......@@ -518,7 +518,7 @@ DEPENDENCIES
em-synchrony (= 1.0.0)
factory_girl_rails (= 1.7.0)
faraday
faraday-stack
faraday_middleware
fastercsv (= 1.5.4)
fixture_builder (= 0.3.3)
fog
......
......@@ -5,6 +5,6 @@ options = {:timeout => 25}
options[:ssl] = {:ca_file => EnviromentConfiguration.ca_cert_file_location}
Faraday.default_connection = Faraday::Connection.new(options) do |b|
b.use FaradayStack::FollowRedirects
b.use FaradayMiddleware::FollowRedirects
b.adapter Faraday.default_adapter
end
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment