Commit 1aa0b15c authored by Steven Hancock's avatar Steven Hancock Committed by Maxwell Salzberg
Browse files

Move Javascript to the asset pipeline

* Move all Diaspora-specific javascripts to app/assets/javascripts
* Move all vendored javascripts to vendor/assets/javascripts
* Add the appropriate Sprockets require directives to make sure
  everything gets included in the right order
* Remove Jammit dependencies
* Fix all templates that were using Jammit's include_javascripts helper
* Add handlebars_assets gem for compiling Handlebars templates
* Move all Handlebars templates to app/assets/templates and rename
  from .handlebars to .jst.hbs (this is to keep them in the same
  global JST namespace that they were in under Jammit)
* Add public/assets to .gitignore since these files can and should
  be re-generated by Heroku or Capistrano during each deploy
* Fix a few Handlebars templates that were looking for images in the
  wrong location (I'm sure there are others, but it's late)
* Configure application.rb to precompile all javascript and css assets
  that were compiled by Jammit in the Rails 3.0 code
parent 9dffb426
......@@ -66,3 +66,7 @@ dump.rdb
#Rubinius's JIT
*.rbc
# Ignore precompiled assets
# Heroku or Capistrano can and should regenerate them on every deploy
public/assets
......@@ -64,8 +64,6 @@ gem 'fastercsv', '1.5.4', :require => false
gem 'mini_magick', '3.4'
gem 'rest-client', '1.6.7'
gem 'jammit-s3'
# JSON and API
gem 'json'
......@@ -113,6 +111,7 @@ group :assets do
gem 'sass-rails'
gem 'uglifier'
end
gem 'handlebars_assets'
gem 'jquery-rails'
......
......@@ -37,10 +37,6 @@ GIT
GEM
remote: http://rubygems.org/
specs:
POpen4 (0.1.4)
Platform (>= 0.4.0)
open4
Platform (0.4.0)
SystemTimer (1.2.3)
actionmailer (3.1.4)
actionpack (= 3.1.4)
......@@ -188,6 +184,10 @@ GEM
gherkin (2.9.1)
json (>= 1.4.6)
haml (3.1.4)
handlebars_assets (0.4.1)
execjs (>= 1.2.9)
sprockets (>= 2.0.3)
tilt
hashie (1.2.0)
heroku (2.23.0)
launchy (>= 0.3.2)
......@@ -209,12 +209,6 @@ GEM
actionpack (~> 3.0)
i18n-inflector (~> 2.6)
railties (~> 3.0)
jammit (0.6.5)
yui-compressor (>= 0.9.3)
jammit-s3 (0.6.0.2)
jammit (>= 0.5.4)
mimemagic (>= 0.1.7)
s3 (>= 0.3.7)
jasmine (1.1.2)
jasmine-core (>= 1.1.0)
rack (>= 1.1)
......@@ -245,7 +239,6 @@ GEM
treetop (~> 1.4.8)
messagebus_ruby_api (1.0.3)
mime-types (1.18)
mimemagic (0.1.8)
mini_magick (3.4)
subexec (~> 0.2.1)
mobile-fu (1.0.0)
......@@ -295,14 +288,12 @@ GEM
omniauth-oauth (~> 1.0)
omniauth-twitter (0.0.8)
omniauth-oauth (~> 1.0)
open4 (1.3.0)
orm_adapter (0.0.6)
parallel (0.5.16)
parallel_tests (0.7.2)
parallel
pg (0.13.2)
polyglot (0.3.3)
proxies (0.2.1)
rack (1.3.6)
rack-cache (1.2)
rack (>= 0.4)
......@@ -396,8 +387,6 @@ GEM
ruby_core_source (0.1.5)
archive-tar-minitar (>= 0.5.2)
rubyzip (0.9.6.1)
s3 (0.3.11)
proxies (~> 0.2.0)
sass (3.1.15)
sass-rails (3.1.6)
actionpack (~> 3.1.0)
......@@ -460,8 +449,6 @@ GEM
xpath (0.1.4)
nokogiri (~> 1.3)
yard (0.7.5)
yui-compressor (0.9.6)
POpen4 (>= 0.1.4)
PLATFORMS
ruby
......@@ -497,11 +484,11 @@ DEPENDENCIES
foreman (= 0.34.1)
fuubar (= 0.0.6)
haml
handlebars_assets
heroku
heroku_san
http_accept_language (~> 1.0.2)
i18n-inflector-rails (~> 1.0)
jammit-s3
jasmine (~> 1.1.2)
jquery-rails
json
......
//= require_self
//= require_tree ./helpers
//= require ./router
//= require ./views
//= require_tree ./models
//= require_tree ./pages
//= require_tree ./collections
//= require_tree ./views
var app = {
collections: {},
models: {},
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment